balena-allwinner/layers/meta-balena-allwinner/recipes-kernel/linux/linux-4.19/0124-drm-lima-Fix-Lima-to-work-with-drm-scheduler-changes.patch
Vicentiu Galanopulo b167421e55 recipes-kernel/linux: Add linux_4.19.76.bb/bbappend
Add the latest linux available
from https://github.com/armbian/build
commit de58ac1faac92724c6449db12c22affaeb003875,
tag: sunxi-5.3, alongside all the patches
that it comes with.

Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
2019-10-10 11:50:43 +02:00

46 lines
1.5 KiB
Diff

From 2b07a3e1c8918d96db4939c85b5eafcffefd2285 Mon Sep 17 00:00:00 2001
From: Andreas Baierl <ichgeh@imkreisrum.de>
Date: Thu, 4 Oct 2018 06:21:09 -0400
Subject: [PATCH 124/146] drm/lima: Fix Lima to work with drm scheduler changes
since 4.19
Signed-off-by: Andreas Baierl <ichgeh@imkreisrum.de>
---
drivers/gpu/drm/lima/lima_sched.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/gpu/drm/lima/lima_sched.c b/drivers/gpu/drm/lima/lima_sched.c
index 1e715e58d33b..d09aae446883 100644
--- a/drivers/gpu/drm/lima/lima_sched.c
+++ b/drivers/gpu/drm/lima/lima_sched.c
@@ -110,8 +110,7 @@ int lima_sched_task_init(struct lima_sched_task *task,
{
int err;
- err = drm_sched_job_init(&task->base, context->base.sched,
- &context->base, vm);
+ err = drm_sched_job_init(&task->base, &context->base, vm);
if (err)
return err;
@@ -169,7 +168,7 @@ int lima_sched_context_init(struct lima_sched_pipe *pipe,
return -ENOMEM;
mutex_init(&context->lock);
- err = drm_sched_entity_init(&pipe->base, &context->base, rq, guilty);
+ err = drm_sched_entity_init(&context->base, &rq, 1, guilty);
if (err) {
kfree(context->fences);
context->fences = NULL;
@@ -182,7 +181,7 @@ int lima_sched_context_init(struct lima_sched_pipe *pipe,
void lima_sched_context_fini(struct lima_sched_pipe *pipe,
struct lima_sched_context *context)
{
- drm_sched_entity_fini(&pipe->base, &context->base);
+ drm_sched_entity_fini(&context->base);
mutex_destroy(&context->lock);
--
2.17.1