balena-allwinner/layers/meta-balena-allwinner/recipes-kernel/linux/linux-4.19/0000-0067-mmc-add-delay-after-power-class-selection.patch
Vicentiu Galanopulo b167421e55 recipes-kernel/linux: Add linux_4.19.76.bb/bbappend
Add the latest linux available
from https://github.com/armbian/build
commit de58ac1faac92724c6449db12c22affaeb003875,
tag: sunxi-5.3, alongside all the patches
that it comes with.

Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
2019-10-10 11:50:43 +02:00

38 lines
1 KiB
Diff

From 2fecbde6fd1e7de568f19caaed3e0db75ac2d585 Mon Sep 17 00:00:00 2001
From: Ondrej Jirman <megous@megous.com>
Date: Fri, 16 Mar 2018 20:31:55 +0100
Subject: [PATCH 67/82] mmc: add delay after power class selection
This seems to fix issue with sporadic ETIMEOUT in eMMC cache
initialization on second generation TBS A711 tablet.
Signed-off-by: Ondrej Jirman <megous@megous.com>
---
drivers/mmc/core/mmc.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/drivers/mmc/core/mmc.c b/drivers/mmc/core/mmc.c
index f1fe446eee66..b29991135375 100644
--- a/drivers/mmc/core/mmc.c
+++ b/drivers/mmc/core/mmc.c
@@ -1770,6 +1770,8 @@ static int mmc_init_card(struct mmc_host *host, u32 ocr,
*/
mmc_select_powerclass(card);
+ msleep(20);
+
/*
* Enable HPI feature (if supported)
*/
@@ -1789,6 +1791,8 @@ static int mmc_init_card(struct mmc_host *host, u32 ocr,
}
}
+ msleep(20);
+
/*
* If cache size is higher than 0, this indicates the existence of cache
* and it can be turned on. Note that some eMMCs from Micron has been
--
2.20.1