
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
46 lines
1.2 KiB
Diff
46 lines
1.2 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h5.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h5.dtsi
|
|
index 67e2246a6..e37d779f8 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h5.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h5.dtsi
|
|
@@ -55,7 +55,6 @@
|
|
clocks = <&ccu CLK_CPUX>;
|
|
clock-names = "cpu";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
- clock-frequency = <1200000000>;
|
|
#cooling-cells = <2>;
|
|
cooling-min-level = <0>;
|
|
cooling-max-level = <15>;
|
|
@@ -67,7 +66,6 @@
|
|
reg = <1>;
|
|
enable-method = "psci";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
- clock-frequency = <1200000000>;
|
|
};
|
|
|
|
cpu@2 {
|
|
@@ -76,7 +74,6 @@
|
|
reg = <2>;
|
|
enable-method = "psci";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
- clock-frequency = <1200000000>;
|
|
};
|
|
|
|
cpu@3 {
|
|
@@ -85,10 +82,16 @@
|
|
reg = <3>;
|
|
enable-method = "psci";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
- clock-frequency = <1200000000>;
|
|
};
|
|
};
|
|
|
|
+ reg_cpu_fallback: reg_cpu_fallback {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vdd-cpux-dummy";
|
|
+ regulator-min-microvolt = <1100000>;
|
|
+ regulator-max-microvolt = <1100000>;
|
|
+ };
|
|
+
|
|
psci {
|
|
compatible = "arm,psci-0.2";
|
|
method = "smc";
|