
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
66 lines
1.8 KiB
Diff
66 lines
1.8 KiB
Diff
From 75347dd025a7da146944c69c724dbd6d24e10100 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Fri, 18 Aug 2017 13:56:06 +0200
|
|
Subject: [PATCH 80/82] Add support for my private Sapomat device
|
|
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
.../boot/dts/sun8i-h3-orangepi-pc-sapomat.dts | 34 +++++++++++++++++++
|
|
2 files changed, 35 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/sun8i-h3-orangepi-pc-sapomat.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
index b5bd3de87c33..c3720b0ffbe1 100644
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -1043,6 +1043,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
|
|
sun8i-h3-orangepi-lite.dtb \
|
|
sun8i-h3-orangepi-one.dtb \
|
|
sun8i-h3-orangepi-pc.dtb \
|
|
+ sun8i-h3-orangepi-pc-sapomat.dtb \
|
|
sun8i-h3-orangepi-pc-plus.dtb \
|
|
sun8i-h3-orangepi-plus.dtb \
|
|
sun8i-h3-orangepi-plus2e.dtb \
|
|
diff --git a/arch/arm/boot/dts/sun8i-h3-orangepi-pc-sapomat.dts b/arch/arm/boot/dts/sun8i-h3-orangepi-pc-sapomat.dts
|
|
new file mode 100644
|
|
index 000000000000..55c82d5fb63f
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/sun8i-h3-orangepi-pc-sapomat.dts
|
|
@@ -0,0 +1,34 @@
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/input/input.h>
|
|
+#include "sun8i-h3-orangepi-pc.dts"
|
|
+
|
|
+/ {
|
|
+ model = "Xunlong Orange Pi PC Sapomat";
|
|
+
|
|
+ sapomat_gpio_keys {
|
|
+ compatible = "gpio-keys-polled";
|
|
+ poll-interval = <50>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&sapomat_btn_pins>;
|
|
+
|
|
+ red_btn {
|
|
+ label = "Red Button";
|
|
+ linux,code = <BTN_4>;
|
|
+ gpios = <&pio 2 4 GPIO_ACTIVE_LOW>; /* PC4 */
|
|
+ };
|
|
+
|
|
+ green_btn {
|
|
+ label = "Green Button";
|
|
+ linux,code = <BTN_5>;
|
|
+ gpios = <&pio 2 7 GPIO_ACTIVE_LOW>; /* PC7 */
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&pio {
|
|
+ sapomat_btn_pins: btn_pins@0 {
|
|
+ pins = "PC4", "PC7";
|
|
+ function = "gpio_in";
|
|
+ bias-pull-up;
|
|
+ };
|
|
+};
|
|
--
|
|
2.20.1
|
|
|