balena-allwinner/layers/meta-balena-allwinner/recipes-kernel/linux/linux-mainline/armbian/0000-0074-Allow-to-disable-cluster2-on-A83T-permanently.patch
Vicentiu Galanopulo 7d5f1dbda1 recipes-kernel/linux: Remove unused patches and householding
Some patches were part of other linux-mainline
kernel versions but are not anymore part of the
current 4.19.76.

Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch
in linux-mainline_4.19.76.bbappend to avoid error
patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts
Hunk #2 FAILED at 162.
1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts

Place all patches from Armbian in a separate directory and do all the Balena specific
operations in linux-mainline_%.bbappend only.

Changelog-entry: Remove unused patches and cleanup
Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
2019-10-14 09:43:01 +02:00

103 lines
2.1 KiB
Diff

From 177d470754881e3cff95d90e6b6d79d96ae92ccd Mon Sep 17 00:00:00 2001
From: Ondrej Jirman <megous@megous.com>
Date: Sat, 28 Jul 2018 00:42:25 +0200
Subject: [PATCH 74/82] Allow to disable cluster2 on A83T permanently
Hotplug is broken for now. Therfore this.
Signed-off-by: Ondrej Jirman <megous@megous.com>
---
arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts | 8 ++++++++
arch/arm/boot/dts/sun8i-a83t.dtsi | 4 ++++
2 files changed, 12 insertions(+)
diff --git a/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts b/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
index 8bba9ccd2592..7a1b6154cda9 100644
--- a/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
+++ b/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
@@ -41,6 +41,8 @@
* OTHER DEALINGS IN THE SOFTWARE.
*/
+#define A83T_C1_DISABLE
+
/dts-v1/;
#include "sun8i-a83t.dtsi"
@@ -188,9 +190,11 @@
cpu-supply = <&reg_dcdc2>;
};
+#ifndef A83T_C1_DISABLE
&cpu100 {
cpu-supply = <&reg_dcdc3>;
};
+#endif
&cpu0_thermal {
trips {
@@ -214,6 +218,7 @@
};
};
+#ifndef A83T_C1_DISABLE
&cpu1_thermal {
trips {
cpu1_hot: cpu_hot {
@@ -235,6 +240,7 @@
};
};
};
+#endif
&csi0 {
status = "okay";
@@ -516,7 +522,9 @@
&reg_dcdc3 {
regulator-min-microvolt = <700000>;
regulator-max-microvolt = <1100000>;
+#ifndef A83T_C1_DISABLE
regulator-always-on;
+#endif
regulator-name = "vdd-cpu-B";
};
diff --git a/arch/arm/boot/dts/sun8i-a83t.dtsi b/arch/arm/boot/dts/sun8i-a83t.dtsi
index 7b87029904bc..0bc7482744d7 100644
--- a/arch/arm/boot/dts/sun8i-a83t.dtsi
+++ b/arch/arm/boot/dts/sun8i-a83t.dtsi
@@ -113,6 +113,7 @@
#cooling-cells = <2>;
};
+#ifndef A83T_C1_DISABLE
cpu100: cpu@100 {
clocks = <&ccu CLK_C1CPUX>;
clock-names = "cpu";
@@ -164,6 +165,7 @@
reg = <0x103>;
#cooling-cells = <2>;
};
+#endif
};
timer {
@@ -274,6 +276,7 @@
};
};
+#ifndef A83T_C1_DISABLE
cpu1_opp_table: opp_table1 {
compatible = "operating-points-v2";
opp-shared;
@@ -326,6 +329,7 @@
clock-latency-ns = <244144>; /* 8 32k periods */
};
};
+#endif
soc {
compatible = "simple-bus";
--
2.20.1