
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
38 lines
1 KiB
Diff
38 lines
1 KiB
Diff
From 2fecbde6fd1e7de568f19caaed3e0db75ac2d585 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Fri, 16 Mar 2018 20:31:55 +0100
|
|
Subject: [PATCH 67/82] mmc: add delay after power class selection
|
|
|
|
This seems to fix issue with sporadic ETIMEOUT in eMMC cache
|
|
initialization on second generation TBS A711 tablet.
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
drivers/mmc/core/mmc.c | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/drivers/mmc/core/mmc.c b/drivers/mmc/core/mmc.c
|
|
index f1fe446eee66..b29991135375 100644
|
|
--- a/drivers/mmc/core/mmc.c
|
|
+++ b/drivers/mmc/core/mmc.c
|
|
@@ -1770,6 +1770,8 @@ static int mmc_init_card(struct mmc_host *host, u32 ocr,
|
|
*/
|
|
mmc_select_powerclass(card);
|
|
|
|
+ msleep(20);
|
|
+
|
|
/*
|
|
* Enable HPI feature (if supported)
|
|
*/
|
|
@@ -1789,6 +1791,8 @@ static int mmc_init_card(struct mmc_host *host, u32 ocr,
|
|
}
|
|
}
|
|
|
|
+ msleep(20);
|
|
+
|
|
/*
|
|
* If cache size is higher than 0, this indicates the existence of cache
|
|
* and it can be turned on. Note that some eMMCs from Micron has been
|
|
--
|
|
2.20.1
|
|
|