
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
50 lines
1.4 KiB
Diff
50 lines
1.4 KiB
Diff
From 6ff7153330ff8a6c3427e6445e5015620d687c81 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Myl=C3=A8ne=20Josserand?= <mylene.josserand@bootlin.com>
|
|
Date: Wed, 25 Jul 2018 09:34:09 +0200
|
|
Subject: [PATCH 18/82] Input: edt-ft5x06 - Set wake/reset values on
|
|
resume/suspend
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
On resume and suspend, set the value of wake and reset gpios
|
|
to be sure that we are in a know state after suspending/resuming.
|
|
|
|
Signed-off-by: Mylène Josserand <mylene.josserand@bootlin.com>
|
|
---
|
|
drivers/input/touchscreen/edt-ft5x06.c | 12 ++++++++++++
|
|
1 file changed, 12 insertions(+)
|
|
|
|
diff --git a/drivers/input/touchscreen/edt-ft5x06.c b/drivers/input/touchscreen/edt-ft5x06.c
|
|
index dcde719094f7..dad2f1f8bf89 100644
|
|
--- a/drivers/input/touchscreen/edt-ft5x06.c
|
|
+++ b/drivers/input/touchscreen/edt-ft5x06.c
|
|
@@ -1158,6 +1158,12 @@ static int __maybe_unused edt_ft5x06_ts_suspend(struct device *dev)
|
|
else
|
|
regulator_disable(tsdata->vcc);
|
|
|
|
+ if (tsdata->wake_gpio)
|
|
+ gpiod_set_value(tsdata->wake_gpio, 0);
|
|
+
|
|
+ if (tsdata->reset_gpio)
|
|
+ gpiod_set_value(tsdata->reset_gpio, 1);
|
|
+
|
|
return 0;
|
|
}
|
|
|
|
@@ -1177,6 +1183,12 @@ static int __maybe_unused edt_ft5x06_ts_resume(struct device *dev)
|
|
}
|
|
}
|
|
|
|
+ if (tsdata->wake_gpio)
|
|
+ gpiod_set_value(tsdata->wake_gpio, 1);
|
|
+
|
|
+ if (tsdata->reset_gpio)
|
|
+ gpiod_set_value(tsdata->reset_gpio, 0);
|
|
+
|
|
return 0;
|
|
}
|
|
|
|
--
|
|
2.20.1
|
|
|