
Add the newest u-boot available in https://github.com/armbian/build alongside all the patches that it comes with. Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
29 lines
1.2 KiB
Diff
29 lines
1.2 KiB
Diff
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
|
index 7311063..f8a0784 100644
|
|
--- a/arch/arm/dts/Makefile
|
|
+++ b/arch/arm/dts/Makefile
|
|
@@ -382,6 +382,7 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
|
|
sun8i-h3-orangepi-lite.dtb \
|
|
sun8i-h3-orangepi-one.dtb \
|
|
sun8i-h3-beelink-x2.dtb \
|
|
+ sun8i-h3-orangepi-zeroplus2.dtb \
|
|
sun8i-h3-orangepi-pc.dtb \
|
|
sun8i-h3-orangepi-pc-plus.dtb \
|
|
sun8i-h3-orangepi-plus.dtb \
|
|
diff --git a/arch/arm/dts/sun8i-h3-orangepi-zero-plus2.dts b/arch/arm/dts/sun8i-h3-orangepi-zeroplus2.dts
|
|
similarity index 100%
|
|
rename from arch/arm/dts/sun8i-h3-orangepi-zero-plus2.dts
|
|
rename to arch/arm/dts/sun8i-h3-orangepi-zeroplus2.dts
|
|
diff --git a/configs/orangepi_zero_plus2_h3_defconfig b/configs/orangepi_zero_plus2_h3_defconfig
|
|
index 98c7e0a..cad0390 100644
|
|
--- a/configs/orangepi_zero_plus2_h3_defconfig
|
|
+++ b/configs/orangepi_zero_plus2_h3_defconfig
|
|
@@ -5,7 +5,7 @@ CONFIG_MACH_SUN8I_H3=y
|
|
CONFIG_DRAM_CLK=408
|
|
CONFIG_DRAM_ZQ=3881979
|
|
CONFIG_DRAM_ODT_EN=y
|
|
-CONFIG_DEFAULT_DEVICE_TREE="sun8i-h3-orangepi-zero-plus2"
|
|
+CONFIG_DEFAULT_DEVICE_TREE="sun8i-h3-orangepi-zeroplus2"
|
|
CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
|
# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
|
|
CONFIG_SPL=y
|