
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
56 lines
1.5 KiB
Diff
56 lines
1.5 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts
|
|
index b4ce2e056..63b9e7433 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts
|
|
@@ -94,6 +94,8 @@
|
|
wifi_pwrseq: wifi_pwrseq {
|
|
compatible = "mmc-pwrseq-simple";
|
|
reset-gpios = <&r_pio 0 8 GPIO_ACTIVE_LOW>; /* PL8 */
|
|
+ clocks = <&rtc 1>;
|
|
+ clock-names = "ext_clock";
|
|
};
|
|
|
|
hdmi-connector {
|
|
@@ -191,6 +193,14 @@
|
|
bus-width = <4>;
|
|
non-removable;
|
|
status = "okay";
|
|
+
|
|
+ brcmf: wifi@1 {
|
|
+ reg = <1>;
|
|
+ compatible = "brcm,bcm4329-fmac";
|
|
+ interrupt-parent = <&r_pio>;
|
|
+ interrupts = <0 7 IRQ_TYPE_LEVEL_LOW>; /* PL7 */
|
|
+ interrupt-names = "host-wake";
|
|
+ };
|
|
};
|
|
|
|
&ohci0 {
|
|
@@ -363,7 +373,20 @@
|
|
&uart1 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart1_pins>, <&uart1_rts_cts_pins>;
|
|
+ uart-has-rtscts;
|
|
status = "okay";
|
|
+
|
|
+ bluetooth {
|
|
+ compatible = "brcm,bcm43438-bt";
|
|
+ max-speed = <1500000>;
|
|
+ clocks = <&rtc 1>;
|
|
+ clock-names = "lpo";
|
|
+ vbat-supply = <®_dldo2>;
|
|
+ vddio-supply = <®_dldo4>;
|
|
+ device-wakeup-gpios = <&r_pio 0 6 GPIO_ACTIVE_HIGH>; /* PL6 */
|
|
+ host-wakeup-gpios = <&r_pio 0 5 GPIO_ACTIVE_HIGH>; /* PL5 */
|
|
+ shutdown-gpios = <&r_pio 0 4 GPIO_ACTIVE_HIGH>; /* PL4 */
|
|
+ };
|
|
};
|
|
|
|
&usb_otg {
|
|
@@ -375,4 +398,4 @@
|
|
usb0_id_det-gpios = <&pio 7 9 GPIO_ACTIVE_HIGH>; /* PH9 */
|
|
usb1_vbus-supply = <®_usb1_vbus>;
|
|
status = "okay";
|
|
-};
|
|
\ No newline at end of file
|
|
+};
|