
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
86 lines
1.7 KiB
Diff
86 lines
1.7 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-olinuxino.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-olinuxino.dts
|
|
index 3792566cd..42b838b1f 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-olinuxino.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-olinuxino.dts
|
|
@@ -94,6 +94,18 @@
|
|
};
|
|
};
|
|
|
|
+&codec {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&codec_analog {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dai {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&de {
|
|
status = "okay";
|
|
};
|
|
@@ -109,6 +121,14 @@
|
|
};
|
|
};
|
|
|
|
+&i2s2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mixer0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&ehci0 {
|
|
status = "okay";
|
|
};
|
|
@@ -194,6 +214,14 @@
|
|
|
|
#include "axp803.dtsi"
|
|
|
|
+&ac_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&battery_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
®_aldo1 {
|
|
regulator-always-on;
|
|
regulator-min-microvolt = <2800000>;
|
|
@@ -316,6 +344,32 @@
|
|
vcc-hdmi-supply = <®_dldo1>;
|
|
};
|
|
|
|
+&sound {
|
|
+ status = "okay";
|
|
+ simple-audio-card,widgets = "Microphone", "Internal Microphone Left",
|
|
+ "Microphone", "Internal Microphone Right",
|
|
+ "Headphone", "Headphone Jack";
|
|
+ simple-audio-card,aux-devs = <&codec_analog>;
|
|
+ simple-audio-card,routing =
|
|
+ "Left DAC", "AIF1 Slot 0 Left",
|
|
+ "Right DAC", "AIF1 Slot 0 Right",
|
|
+ "INL", "LINEOUT",
|
|
+ "INR", "LINEOUT",
|
|
+ "Headphone Jack", "HP",
|
|
+ "AIF1 Slot 0 Left ADC", "Left ADC",
|
|
+ "AIF1 Slot 0 Right ADC", "Right ADC",
|
|
+ "Left ADC", "ADC",
|
|
+ "Right ADC", "ADC",
|
|
+ "Internal Microphone Left", "MBIAS",
|
|
+ "MIC1", "Internal Microphone Left",
|
|
+ "Internal Microphone Right", "HBIAS",
|
|
+ "MIC2", "Internal Microphone Right";
|
|
+};
|
|
+
|
|
+&sound_hdmi {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_pins_a>;
|