
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
181 lines
3.6 KiB
Diff
181 lines
3.6 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts
|
|
index eefe0a458..b5cb62beb 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-orangepi-win.dts
|
|
@@ -52,6 +52,7 @@
|
|
compatible = "xunlong,orangepi-win", "allwinner,sun50i-a64";
|
|
|
|
aliases {
|
|
+ ethernet0 = &emac;
|
|
serial0 = &uart0;
|
|
};
|
|
|
|
@@ -59,6 +60,43 @@
|
|
stdout-path = "serial0:115200n8";
|
|
};
|
|
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ status {
|
|
+ label = "orangepi:green:status";
|
|
+ gpios = <&pio 7 11 GPIO_ACTIVE_HIGH>; /* PH11 */
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <100000>;
|
|
+ regulator-boot-on;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 3 14 GPIO_ACTIVE_HIGH>; /* PD14 */
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ reg_usb1_vbus: usb1-vbus {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "usb1-vbus";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ regulator-boot-on;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 3 7 GPIO_ACTIVE_HIGH>; /* PD7 */
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ wifi_pwrseq: wifi_pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&r_pio 0 8 GPIO_ACTIVE_LOW>; /* PL8 */
|
|
+ };
|
|
+
|
|
hdmi-connector {
|
|
compatible = "hdmi-connector";
|
|
type = "a";
|
|
@@ -72,10 +109,26 @@
|
|
|
|
};
|
|
|
|
+&codec {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&codec_analog {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dai {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&de {
|
|
status = "okay";
|
|
};
|
|
|
|
+&cpu0 {
|
|
+ cpu-supply = <®_dcdc2>;
|
|
+};
|
|
+
|
|
&ehci1 {
|
|
status = "okay";
|
|
};
|
|
@@ -91,14 +144,51 @@
|
|
};
|
|
};
|
|
|
|
+&i2s2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mixer0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&rgmii_pins>;
|
|
+ phy-mode = "rgmii";
|
|
+ phy-handle = <&ext_rgmii_phy>;
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mdio {
|
|
+ ext_rgmii_phy: ethernet-phy@1 {
|
|
+ compatible = "ethernet-phy-ieee802.3-c22";
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
&mmc0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&mmc0_pins>;
|
|
vmmc-supply = <®_dcdc1>;
|
|
- cd-gpios = <&pio 5 6 GPIO_ACTIVE_LOW>;
|
|
+ cd-gpios = <&pio 5 6 GPIO_ACTIVE_LOW>; /* PF6 */
|
|
+ disable-wp;
|
|
+ bus-width = <4>;
|
|
status = "okay";
|
|
};
|
|
|
|
+&mmc1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc1_pins>;
|
|
+ vmmc-supply = <®_dldo2>;
|
|
+ vqmmc-supply = <®_dldo4>;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+ bus-width = <4>;
|
|
+ non-removable;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&ohci1 {
|
|
status = "okay";
|
|
};
|
|
@@ -116,6 +206,14 @@
|
|
|
|
#include "axp803.dtsi"
|
|
|
|
+&ac_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&battery_power_supply {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
®_aldo1 {
|
|
regulator-min-microvolt = <2800000>;
|
|
regulator-max-microvolt = <2800000>;
|
|
@@ -228,6 +326,30 @@
|
|
vcc-hdmi-supply = <®_dldo1>;
|
|
};
|
|
|
|
+&sound {
|
|
+ status = "okay";
|
|
+ simple-audio-card,widgets = "Microphone", "Internal Microphone Left",
|
|
+ "Microphone", "Internal Microphone Right",
|
|
+ "Headphone", "Headphone Jack";
|
|
+ simple-audio-card,aux-devs = <&codec_analog>;
|
|
+ simple-audio-card,routing =
|
|
+ "Left DAC", "AIF1 Slot 0 Left",
|
|
+ "Right DAC", "AIF1 Slot 0 Right",
|
|
+ "Headphone Jack", "HP",
|
|
+ "AIF1 Slot 0 Left ADC", "Left ADC",
|
|
+ "AIF1 Slot 0 Right ADC", "Right ADC",
|
|
+ "Left ADC", "ADC",
|
|
+ "Right ADC", "ADC",
|
|
+ "Internal Microphone Left", "MBIAS",
|
|
+ "MIC1", "Internal Microphone Left",
|
|
+ "Internal Microphone Right", "HBIAS",
|
|
+ "MIC2", "Internal Microphone Right";
|
|
+};
|
|
+
|
|
+&sound_hdmi {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
status = "okay";
|