
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
45 lines
1.2 KiB
Diff
45 lines
1.2 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h5-nanopi-neo-plus2.dts b/arch/arm64/boot/dts/allwinner/sun50i-h5-nanopi-neo-plus2.dts
|
|
index 506e25b..bc42210 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h5-nanopi-neo-plus2.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h5-nanopi-neo-plus2.dts
|
|
@@ -65,14 +65,15 @@
|
|
compatible = "gpio-leds";
|
|
|
|
pwr {
|
|
- label = "nanopi:green:pwr";
|
|
- gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>;
|
|
- default-state = "on";
|
|
+ label = "nanopi:red:pwr";
|
|
+ gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>; /* PL10 */
|
|
+ linux,default-trigger = "default-on";
|
|
};
|
|
|
|
status {
|
|
- label = "nanopi:red:status";
|
|
- gpios = <&pio 0 20 GPIO_ACTIVE_HIGH>;
|
|
+ label = "nanopi:green:status";
|
|
+ gpios = <&pio 0 10 GPIO_ACTIVE_HIGH>; /* PA10 */
|
|
+ linux,default-trigger = "heartbeat";
|
|
};
|
|
};
|
|
|
|
@@ -104,7 +105,7 @@
|
|
regulator-min-microvolt = <1100000>;
|
|
regulator-max-microvolt = <1300000>;
|
|
regulator-ramp-delay = <50>; /* 4ms */
|
|
- gpios = <&r_pio 0 6 GPIO_ACTIVE_HIGH>;
|
|
+ gpios = <&r_pio 0 6 GPIO_ACTIVE_HIGH>; /* PL6 */
|
|
gpios-states = <0x1>;
|
|
states = <1100000 0x0
|
|
1300000 0x1>;
|
|
@@ -118,6 +119,10 @@
|
|
};
|
|
};
|
|
|
|
+&cpu0 {
|
|
+ cpu-supply = <&vdd_cpux>;
|
|
+};
|
|
+
|
|
&codec {
|
|
allwinner,audio-routing =
|
|
"Line Out", "LINEOUT",
|