
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
21 lines
791 B
Diff
21 lines
791 B
Diff
diff --git a/drivers/spi/spidev.c b/drivers/spi/spidev.c
|
|
index 9e2e099b..a065943d 100644
|
|
--- a/drivers/spi/spidev.c
|
|
+++ b/drivers/spi/spidev.c
|
|
@@ -749,13 +749,11 @@ static int spidev_probe(struct spi_device *spi)
|
|
|
|
/*
|
|
* spidev should never be referenced in DT without a specific
|
|
- * compatible string, it is a Linux implementation thing
|
|
- * rather than a description of the hardware.
|
|
+ * compatible string, but people don't care and use DT overlays
|
|
+ * to activate SPIdev on demand
|
|
*/
|
|
if (spi->dev.of_node && !of_match_device(spidev_dt_ids, &spi->dev)) {
|
|
- dev_err(&spi->dev, "buggy DT: spidev listed directly in DT\n");
|
|
- WARN_ON(spi->dev.of_node &&
|
|
- !of_match_device(spidev_dt_ids, &spi->dev));
|
|
+ dev_info(&spi->dev, "probing from DT");
|
|
}
|
|
|
|
spidev_probe_acpi(spi);
|