
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
14 lines
440 B
Diff
14 lines
440 B
Diff
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
|
index 1ca4dcd..3288146 100644
|
|
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -278,7 +278,8 @@ DTC_FLAGS += -Wnode_name_chars_strict \
|
|
-Wproperty_name_chars_strict
|
|
endif
|
|
|
|
-DTC_FLAGS += $(DTC_FLAGS_$(basetarget))
|
|
+DTC_FLAGS += $(DTC_FLAGS_$(basetarget)) \
|
|
+ -@
|
|
|
|
# Generate an assembly file to wrap the output of the device tree compiler
|
|
quiet_cmd_dt_S_dtb= DTB $@
|