
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
15 lines
712 B
Diff
15 lines
712 B
Diff
diff --git a/drivers/mtd/nand/nand_ids.c b/drivers/mtd/nand/nand_ids.c
|
|
index 2af9869..f561b36 100644
|
|
--- a/drivers/mtd/nand/raw/nand_ids.c
|
|
+++ b/drivers/mtd/nand/raw/nand_ids.c
|
|
@@ -48,6 +48,10 @@ struct nand_flash_dev nand_flash_ids[] = {
|
|
{"SDTNRGAMA 64G 3.3V 8-bit",
|
|
{ .id = {0x45, 0xde, 0x94, 0x93, 0x76, 0x50} },
|
|
SZ_16K, SZ_8K, SZ_4M, 0, 6, 1280, NAND_ECC_INFO(40, SZ_1K) },
|
|
+ {"H27UBG8T2BTR-BC 32G 3.3V 8-bit",
|
|
+ { .id = {0xad, 0xd7, 0x94, 0xda, 0x74, 0xc3} },
|
|
+ SZ_8K, SZ_4K, SZ_2M, NAND_NEED_SCRAMBLING, 6, 640,
|
|
+ NAND_ECC_INFO(40, SZ_1K), 0 },
|
|
{"H27UCG8T2ATR-BC 64G 3.3V 8-bit",
|
|
{ .id = {0xad, 0xde, 0x94, 0xda, 0x74, 0xc4} },
|
|
SZ_8K, SZ_8K, SZ_2M, NAND_NEED_SCRAMBLING, 6, 640,
|