
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
21 lines
537 B
Diff
21 lines
537 B
Diff
diff --git a/arch/arm/boot/dts/sunxi-h3-h5.dtsi b/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
index 1be1a02..dc9775d 100644
|
|
--- a/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
+++ b/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
@@ -416,6 +416,16 @@
|
|
function = "i2c2";
|
|
};
|
|
|
|
+ i2s0_pins: i2s0 {
|
|
+ pins = "PA18", "PA19", "PA20", "PA21";
|
|
+ function = "i2s0";
|
|
+ };
|
|
+
|
|
+ i2s1_pins: i2s1 {
|
|
+ pins = "PG10", "PG11", "PG12", "PG13";
|
|
+ function = "i2s1";
|
|
+ };
|
|
+
|
|
mmc0_pins: mmc0 {
|
|
pins = "PF0", "PF1", "PF2", "PF3",
|
|
"PF4", "PF5";
|