
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
30 lines
859 B
Diff
30 lines
859 B
Diff
diff --git a/drivers/gpu/drm/sun4i/sun8i_mixer.c b/drivers/gpu/drm/sun4i/sun8i_mixer.c
|
|
index 126899d..7fa7494 100644
|
|
--- a/drivers/gpu/drm/sun4i/sun8i_mixer.c
|
|
+++ b/drivers/gpu/drm/sun4i/sun8i_mixer.c
|
|
@@ -500,6 +500,14 @@ static const struct sun8i_mixer_cfg sun8i_h3_mixer0_cfg = {
|
|
.vi_num = 1,
|
|
};
|
|
|
|
+static const struct sun8i_mixer_cfg sun8i_h3_mixer1_cfg = {
|
|
+ .ccsc = 1,
|
|
+ .mod_rate = 432000000,
|
|
+ .scaler_mask = 0xf,
|
|
+ .ui_num = 3,
|
|
+ .vi_num = 1,
|
|
+};
|
|
+
|
|
static const struct sun8i_mixer_cfg sun8i_v3s_mixer_cfg = {
|
|
.vi_num = 2,
|
|
.ui_num = 1,
|
|
@@ -522,6 +530,10 @@ static const struct of_device_id sun8i_mixer_of_table[] = {
|
|
.data = &sun8i_h3_mixer0_cfg,
|
|
},
|
|
{
|
|
+ .compatible = "allwinner,sun8i-h3-de2-mixer-1",
|
|
+ .data = &sun8i_h3_mixer1_cfg,
|
|
+ },
|
|
+ {
|
|
.compatible = "allwinner,sun8i-v3s-de2-mixer",
|
|
.data = &sun8i_v3s_mixer_cfg,
|
|
},
|