
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
60 lines
1.6 KiB
Diff
60 lines
1.6 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index c72da8c..41a057e 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -128,6 +128,21 @@
|
|
pins = "PH0", "PH1";
|
|
function = "uart0";
|
|
};
|
|
+
|
|
+ uart1_pins: uart1 {
|
|
+ pins = "PG6", "PG7", "PG8", "PG9";
|
|
+ function = "uart1";
|
|
+ };
|
|
+
|
|
+ uart2_pins: uart2 {
|
|
+ pins = "PD19", "PD20";
|
|
+ function = "uart2";
|
|
+ };
|
|
+
|
|
+ uart3_pins: uart3 {
|
|
+ pins = "PD23", "PD24", "PD25", "PD26";
|
|
+ function = "uart3";
|
|
+ };
|
|
};
|
|
|
|
uart0: serial@5000000 {
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-one-plus.dts b/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-one-plus.dts
|
|
index 4d8ca45..f05c995 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-one-plus.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-one-plus.dts
|
|
@@ -242,6 +242,12 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&uart3 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart3_pins>;
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
&usb2otg {
|
|
dr_mode = "host";
|
|
status = "okay";
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-lite2.dts b/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-lite2.dts
|
|
index 4d8ca45..f05c995 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-lite2.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi-lite2.dts
|
|
@@ -242,6 +242,12 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&uart3 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart3_pins>;
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
&usb2otg {
|
|
dr_mode = "host";
|
|
status = "okay";
|