
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
42 lines
1 KiB
Diff
42 lines
1 KiB
Diff
diff --git a/arch/arm/boot/dts/sun8i-r40.dtsi b/arch/arm/boot/dts/sun8i-r40.dtsi
|
|
index bd97ca3..a8a522f 100644
|
|
--- a/arch/arm/boot/dts/sun8i-r40.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-r40.dtsi
|
|
@@ -68,6 +71,23 @@
|
|
clock-frequency = <32768>;
|
|
clock-output-names = "osc32k";
|
|
};
|
|
+
|
|
+ osc24M_32k: clk@1 {
|
|
+ #clock-cells = <0>;
|
|
+ compatible = "fixed-factor-clock";
|
|
+ clock-div = <732>;
|
|
+ clock-mult = <1>;
|
|
+ clocks = <&osc24M>;
|
|
+ clock-output-names = "osc24M_32k";
|
|
+ };
|
|
+
|
|
+ clk_out_a: clk@01c201f0 {
|
|
+ #clock-cells = <0>;
|
|
+ compatible = "allwinner,sun7i-a20-out-clk";
|
|
+ reg = <0x01c201f0 0x4>;
|
|
+ clocks = <&osc24M_32k>, <&osc32k>, <&osc24M>;
|
|
+ clock-output-names = "clk_out_a";
|
|
+ };
|
|
};
|
|
|
|
cpus {
|
|
@@ -265,6 +340,13 @@
|
|
#interrupt-cells = <3>;
|
|
#gpio-cells = <3>;
|
|
|
|
+ clk_out_a_pin: clk-out-a-pin {
|
|
+ pins = "PI12";
|
|
+ function = "clk_out_a";
|
|
+ drive = <0>;
|
|
+ pull = <0>;
|
|
+ };
|
|
+
|
|
gmac_rgmii_pins: gmac-rgmii-pins {
|
|
pins = "PA0", "PA1", "PA2", "PA3",
|
|
"PA4", "PA5", "PA6", "PA7",
|