
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
37 lines
1.4 KiB
Diff
37 lines
1.4 KiB
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-pine64.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-pine64.dts
|
|
index 7161b06..66b8fa7 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-pine64.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-pine64.dts
|
|
@@ -124,3 +124,32 @@
|
|
allwinner,leds-active-low;
|
|
status = "okay";
|
|
};
|
|
+
|
|
+&spi0 {
|
|
+ status = "okay";
|
|
+ spi-flash@0 {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ compatible = "jedec,spi-nor";
|
|
+ reg = <0>; /* Chip select 0 */
|
|
+ spi-max-frequency = <10000000>;
|
|
+ status = "disabled";
|
|
+ partitions {
|
|
+ compatible = "fixed-partitions";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ partition@0 {
|
|
+ label = "uboot";
|
|
+ reg = <0x0 0x100000>;
|
|
+ };
|
|
+ partition@100000 {
|
|
+ label = "env";
|
|
+ reg = <0x100000 0x100000>;
|
|
+ };
|
|
+ partition@200000 {
|
|
+ label = "data";
|
|
+ reg = <0x200000 0x200000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|