
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
73 lines
1.8 KiB
Diff
73 lines
1.8 KiB
Diff
From 66ae9ca01bd3d7f111952ff60f8eef782e6151c1 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Wed, 10 Jan 2018 00:16:29 +0800
|
|
Subject: [PATCH 35/35] arm64: allwinner: h6: add support for the Ethernet on
|
|
Pine H64
|
|
|
|
The Pine H64 board has an Ethernet port, which is connected to a
|
|
RTL8211E PHY, then the PHY is connected to the MAC on H6 SoC.
|
|
|
|
Add support for the Ethernet port.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
.../boot/dts/allwinner/sun50i-h6-pine-h64.dts | 29 ++++++++++++++++++++++
|
|
1 file changed, 29 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts b/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts
|
|
index 7f8e958..b6f353d 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts
|
|
@@ -15,6 +15,7 @@
|
|
compatible = "pine64,pine-h64", "allwinner,sun50i-h6";
|
|
|
|
aliases {
|
|
+ ethernet0 = &emac;
|
|
serial0 = &uart0;
|
|
};
|
|
|
|
@@ -22,6 +23,16 @@
|
|
stdout-path = "serial0:115200n8";
|
|
};
|
|
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vcc-gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <100000>;
|
|
+ gpio = <&pio 2 16 GPIO_ACTIVE_HIGH>;
|
|
+ enable-active-high;
|
|
+ };
|
|
+
|
|
reg_vcc3v3: vcc3v3 {
|
|
compatible = "regulator-fixed";
|
|
regulator-name = "vcc3v3";
|
|
@@ -63,6 +74,24 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&emac {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&ext_rgmii_pins>;
|
|
+ phy-mode = "rgmii";
|
|
+ phy-handle = <&ext_rgmii_phy>;
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ allwinner,rx-delay-ps = <200>;
|
|
+ allwinner,tx-delay-ps = <200>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mdio {
|
|
+ ext_rgmii_phy: ethernet-phy@1 {
|
|
+ compatible = "ethernet-phy-ieee802.3-c22";
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
&mmc0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&mmc0_pins>;
|
|
--
|
|
2.7.4
|
|
|