
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
77 lines
2.1 KiB
Diff
77 lines
2.1 KiB
Diff
From 07a78eea37bdd34619ac73ed828a900166d41f02 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Wed, 10 Jan 2018 00:09:54 +0800
|
|
Subject: [PATCH 34/35] arm64: allwinner: h6: add EMAC device nodes
|
|
|
|
Allwinner H6 SoC has an EMAC like the one in A64.
|
|
|
|
Add device tree nodes for the H6 DTSI file.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi | 35 ++++++++++++++++++++++++++++
|
|
1 file changed, 35 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index f548eb4..2c0ecf7 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -118,6 +118,12 @@
|
|
#size-cells = <1>;
|
|
ranges;
|
|
|
|
+ syscon: syscon@3000000 {
|
|
+ compatible = "allwinner,sun50i-h6-system-controller",
|
|
+ "syscon";
|
|
+ reg = <0x03000000 0x1000>;
|
|
+ };
|
|
+
|
|
ccu: clock@3001000 {
|
|
compatible = "allwinner,sun50i-h6-ccu";
|
|
reg = <0x03001000 0x1000>;
|
|
@@ -152,6 +158,14 @@
|
|
interrupt-controller;
|
|
#interrupt-cells = <3>;
|
|
|
|
+ ext_rgmii_pins: rgmii_pins {
|
|
+ pins = "PD0", "PD1", "PD2", "PD3", "PD4",
|
|
+ "PD5", "PD7", "PD8", "PD9", "PD10",
|
|
+ "PD11", "PD12", "PD13", "PD19", "PD20";
|
|
+ function = "emac";
|
|
+ drive-strength = <40>;
|
|
+ };
|
|
+
|
|
mmc0_pins: mmc0-pins {
|
|
pins = "PF0", "PF1", "PF2", "PF3",
|
|
"PF4", "PF5";
|
|
@@ -313,6 +327,27 @@
|
|
status = "disabled";
|
|
};
|
|
|
|
+ emac: ethernet@5020000 {
|
|
+ compatible = "allwinner,sun50i-h6-emac";
|
|
+ syscon = <&syscon>;
|
|
+ reg = <0x05020000 0x10000>;
|
|
+ interrupts = <GIC_SPI 12 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ interrupt-names = "macirq";
|
|
+ resets = <&ccu RST_BUS_EMAC>;
|
|
+ reset-names = "stmmaceth";
|
|
+ clocks = <&ccu CLK_BUS_EMAC>;
|
|
+ clock-names = "stmmaceth";
|
|
+ status = "disabled";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ mdio: mdio {
|
|
+ compatible = "snps,dwmac-mdio";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ };
|
|
+ };
|
|
+
|
|
usb3: usb@5200000 {
|
|
compatible = "allwinner,sun50i-h6-dwc3";
|
|
#address-cells = <1>;
|
|
--
|
|
2.7.4
|
|
|