
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
64 lines
2.1 KiB
Diff
64 lines
2.1 KiB
Diff
From 768bea287708624e841ff9ae92fa08e66f59c3b2 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Mon, 25 Dec 2017 12:08:01 +0800
|
|
Subject: [PATCH 21/35] dt-bindings: usb: add binding for the DWC3 controller
|
|
on Allwinner SoC
|
|
|
|
The Allwinner H6 SoC uses DWC3 controller for USB3.
|
|
|
|
Add its device tree binding document.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
.../devicetree/bindings/usb/allwinner,dwc3.txt | 39 ++++++++++++++++++++++
|
|
1 file changed, 39 insertions(+)
|
|
create mode 100644 Documentation/devicetree/bindings/usb/allwinner,dwc3.txt
|
|
|
|
diff --git a/Documentation/devicetree/bindings/usb/allwinner,dwc3.txt b/Documentation/devicetree/bindings/usb/allwinner,dwc3.txt
|
|
new file mode 100644
|
|
index 0000000..3f77146
|
|
--- /dev/null
|
|
+++ b/Documentation/devicetree/bindings/usb/allwinner,dwc3.txt
|
|
@@ -0,0 +1,39 @@
|
|
+Allwinner SuperSpeed DWC3 USB SoC controller
|
|
+
|
|
+Required properties:
|
|
+- compatible: should contain "allwinner,sun50i-h6-dwc3" for H6 SoC
|
|
+- clocks: A list of phandle + clock-specifier pairs for the
|
|
+ clocks listed in clock-names
|
|
+- clock-names: Should contain the following:
|
|
+ "bus" The bus clock of the DWC3 part
|
|
+- resets: A list of phandle + reset-specifier pairs for the
|
|
+ resets listed in reset-names
|
|
+- reset-names: Should contain the following:
|
|
+ "bus" The bus reset of the DWC3 part
|
|
+
|
|
+Required child node:
|
|
+A child node must exist to represent the core DWC3 IP block. The name of
|
|
+the node is not important. The content of the node is defined in dwc3.txt.
|
|
+
|
|
+Phy documentation is provided in the following places:
|
|
+Documentation/devicetree/bindings/phy/sun50i-usb3-phy.txt
|
|
+
|
|
+Example device nodes:
|
|
+ usb3: usb@5200000 {
|
|
+ compatible = "allwinner,sun50i-h6-dwc3";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ ranges;
|
|
+ clocks = <&ccu CLK_BUS_XHCI>;
|
|
+ clock-names = "bus";
|
|
+ resets = <&ccu RST_BUS_XHCI>;
|
|
+ reset-names = "bus";
|
|
+
|
|
+ dwc3: dwc3 {
|
|
+ compatible = "snps,dwc3";
|
|
+ reg = <0x5200000 0x10000>;
|
|
+ interrupts = <GIC_SPI 26 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ phys = <&usb3phy>;
|
|
+ phy-names = "usb3-phy";
|
|
+ };
|
|
+ };
|
|
--
|
|
2.7.4
|
|
|