
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
55 lines
1.5 KiB
Groff
55 lines
1.5 KiB
Groff
From ccc7d2a5f907e060a1ed4b6b8f447b0721f36543 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Sat, 23 Dec 2017 10:40:13 +0800
|
|
Subject: [PATCH 15/35] arm64: allwinner: h6: add R_I2C controller
|
|
|
|
Allwinner H6 SoC has a R_I2C controller wired to the PL0/PL1 pins, which
|
|
are used in the reference design to connect AXP805 PMIC.
|
|
|
|
Add support for it.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi | 18 ++++++++++++++++++
|
|
1 file changed, 18 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index 0ff9406..f3ca411 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -6,7 +6,9 @@
|
|
|
|
#include <dt-bindings/interrupt-controller/arm-gic.h>
|
|
#include <dt-bindings/clock/sun50i-h6-ccu.h>
|
|
+#include <dt-bindings/clock/sun50i-h6-r-ccu.h>
|
|
#include <dt-bindings/reset/sun50i-h6-ccu.h>
|
|
+#include <dt-bindings/reset/sun50i-h6-r-ccu.h>
|
|
|
|
/ {
|
|
interrupt-parent = <&gic>;
|
|
@@ -261,6 +263,22 @@
|
|
#gpio-cells = <3>;
|
|
interrupt-controller;
|
|
#interrupt-cells = <3>;
|
|
+
|
|
+ r_i2c_pins: r-i2c {
|
|
+ pins = "PL0", "PL1";
|
|
+ function = "s_i2c";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ r_i2c: i2c@7081400 {
|
|
+ compatible = "allwinner,sun6i-a31-i2c";
|
|
+ reg = <0x07081400 0x400>;
|
|
+ interrupts = <GIC_SPI 107 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ clocks = <&r_ccu CLK_R_APB2_I2C>;
|
|
+ resets = <&r_ccu RST_R_APB2_I2C>;
|
|
+ status = "disabled";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
};
|
|
};
|
|
};
|
|
--
|
|
2.7.4
|
|
|