
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
39 lines
1.2 KiB
Groff
39 lines
1.2 KiB
Groff
From 8b42729766b4ae04e0feafcc58dc6991ace78c02 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Sat, 23 Dec 2017 10:35:22 +0800
|
|
Subject: [PATCH 14/35] arm64: allwinner: h6: add R_INTC interrupt controller
|
|
|
|
Allwinner H6 SoC has also a R_INTC interrupt controller like Allwinner
|
|
A64 SoC, but has its base address changed due to the memory map change
|
|
in H6.
|
|
|
|
Add it into the device tree.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index 41fa2c6..0ff9406 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -241,6 +241,15 @@
|
|
#reset-cells = <1>;
|
|
};
|
|
|
|
+ r_intc: interrupt-controller@7021000 {
|
|
+ compatible = "allwinner,sun50i-h6-r-intc",
|
|
+ "allwinner,sun6i-a31-r-intc";
|
|
+ interrupt-controller;
|
|
+ #interrupt-cells = <2>;
|
|
+ reg = <0x07021000 0x400>;
|
|
+ interrupts = <GIC_SPI 96 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ };
|
|
+
|
|
r_pio: pinctrl@7022000 {
|
|
compatible = "allwinner,sun50i-h6-r-pinctrl";
|
|
reg = <0x07022000 0x400>;
|
|
--
|
|
2.7.4
|
|
|