
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
41 lines
1.2 KiB
Groff
41 lines
1.2 KiB
Groff
From 958d54aad158b794f29f52567b96cd3ed8e0cae2 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Sat, 23 Dec 2017 00:20:21 +0800
|
|
Subject: [PATCH 13/35] arm64: allwinner: h6: add node for R_PIO pin controller
|
|
|
|
Allwinner H6 SoC has a R_PIO pin controller which controls PL and PM
|
|
GPIO banks.
|
|
|
|
Add support for it.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi | 13 +++++++++++++
|
|
1 file changed, 13 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index db0263e..41fa2c6 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -240,5 +240,18 @@
|
|
#clock-cells = <1>;
|
|
#reset-cells = <1>;
|
|
};
|
|
+
|
|
+ r_pio: pinctrl@7022000 {
|
|
+ compatible = "allwinner,sun50i-h6-r-pinctrl";
|
|
+ reg = <0x07022000 0x400>;
|
|
+ interrupts = <GIC_SPI 105 IRQ_TYPE_LEVEL_HIGH>,
|
|
+ <GIC_SPI 111 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ clocks = <&r_ccu CLK_R_APB1>, <&osc24M>, <&osc32k>;
|
|
+ clock-names = "apb", "hosc", "losc";
|
|
+ gpio-controller;
|
|
+ #gpio-cells = <3>;
|
|
+ interrupt-controller;
|
|
+ #interrupt-cells = <3>;
|
|
+ };
|
|
};
|
|
};
|
|
--
|
|
2.7.4
|
|
|