
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
37 lines
1.1 KiB
Groff
37 lines
1.1 KiB
Groff
From 850cc97f8a8ee366f307b8f3a13c6d73fbc069a0 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Fri, 22 Dec 2017 22:11:44 +0800
|
|
Subject: [PATCH 11/35] arm64: allwinner: h6: add PRCM CCU device node
|
|
|
|
Allwinner H6 has also a PRCM CCU.
|
|
|
|
Add its device node into the device tree.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi | 10 ++++++++++
|
|
1 file changed, 10 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index 19c7ee8..db0263e 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -230,5 +230,15 @@
|
|
resets = <&ccu RST_BUS_UART3>;
|
|
status = "disabled";
|
|
};
|
|
+
|
|
+ r_ccu: clock@7010000 {
|
|
+ compatible = "allwinner,sun50i-h6-r-ccu";
|
|
+ reg = <0x07010000 0x400>;
|
|
+ clocks = <&osc24M>, <&osc32k>, <&iosc>,
|
|
+ <&ccu CLK_PLL_PERIPH0>;
|
|
+ clock-names = "hosc", "losc", "iosc", "pll-periph";
|
|
+ #clock-cells = <1>;
|
|
+ #reset-cells = <1>;
|
|
+ };
|
|
};
|
|
};
|
|
--
|
|
2.7.4
|
|
|