
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
35 lines
1,004 B
Diff
35 lines
1,004 B
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
index bec8c4a..73ed36d 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6.dtsi
|
|
@@ -124,6 +124,13 @@
|
|
clock-output-names = "osc32k";
|
|
};
|
|
|
|
+ ext_osc32k: ext_osc32k_clk {
|
|
+ #clock-cells = <0>;
|
|
+ compatible = "fixed-clock";
|
|
+ clock-frequency = <32768>;
|
|
+ clock-output-names = "ext_osc32k";
|
|
+ };
|
|
+
|
|
psci {
|
|
compatible = "arm,psci-0.2";
|
|
method = "smc";
|
|
@@ -511,6 +526,16 @@
|
|
#reset-cells = <1>;
|
|
};
|
|
|
|
+ rtc: rtc@7000000 {
|
|
+ compatible = "allwinner,sun6i-a31-rtc";
|
|
+ reg = <0x07000000 0x54>;
|
|
+ interrupts = <GIC_SPI 40 IRQ_TYPE_LEVEL_HIGH>,
|
|
+ <GIC_SPI 41 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ clock-output-names = "rtc-osc32k", "rtc-osc32k-out";
|
|
+ clocks = <&ext_osc32k>;
|
|
+ #clock-cells = <1>;
|
|
+ };
|
|
+
|
|
r_intc: interrupt-controller@7021000 {
|
|
compatible = "allwinner,sun50i-h6-r-intc",
|
|
"allwinner,sun6i-a31-r-intc";
|