
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
27 lines
784 B
Diff
27 lines
784 B
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus2.dts b/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus2.dts
|
|
index 53c8c116..50ad2e4f 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus2.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus2.dts
|
|
@@ -82,6 +82,22 @@
|
|
reset-gpios = <&pio 0 9 GPIO_ACTIVE_LOW>; /* PA9 */
|
|
post-power-on-delay-ms = <200>;
|
|
};
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ pwr {
|
|
+ label = "orangepi:green:pwr";
|
|
+ gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>; /* PL10 */
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ status {
|
|
+ label = "orangepi:red:status";
|
|
+ gpios = <&pio 0 17 GPIO_ACTIVE_HIGH>; /* PA17 */
|
|
+ linux,default-trigger = "heartbeat";
|
|
+ };
|
|
+ };
|
|
};
|
|
|
|
&de {
|