
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
28 lines
797 B
Diff
28 lines
797 B
Diff
diff --git a/arch/arm/boot/dts/sunxi-h3-h5.dtsi b/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
index c3bff11..48b8447 100644
|
|
--- a/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
+++ b/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
@@ -96,6 +112,13 @@
|
|
clock-output-names = "osc32k";
|
|
};
|
|
|
|
+ ext_osc32k: ext_osc32k_clk {
|
|
+ #clock-cells = <0>;
|
|
+ compatible = "fixed-clock";
|
|
+ clock-frequency = <32768>;
|
|
+ clock-output-names = "ext_osc32k";
|
|
+ };
|
|
+
|
|
iosc: internal-osc-clk {
|
|
#clock-cells = <0>;
|
|
compatible = "fixed-clock";
|
|
@@ -795,6 +861,9 @@
|
|
reg = <0x01f00000 0x54>;
|
|
interrupts = <GIC_SPI 40 IRQ_TYPE_LEVEL_HIGH>,
|
|
<GIC_SPI 41 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ clock-output-names = "rtc-osc32k", "rtc-osc32k-out";
|
|
+ clocks = <&ext_osc32k>;
|
|
+ #clock-cells = <1>;
|
|
};
|
|
|
|
r_ccu: clock@1f01400 {
|