
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
25 lines
512 B
Diff
25 lines
512 B
Diff
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
|
index 8da939a..42fd205 100644
|
|
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
|
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
|
@@ -56,6 +56,7 @@
|
|
|
|
aliases {
|
|
serial0 = &uart0;
|
|
+ serial2 = &uart2;
|
|
};
|
|
|
|
chosen {
|
|
@@ -307,6 +308,12 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&uart2 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart2_pins_a>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&usb_otg {
|
|
dr_mode = "otg";
|
|
status = "okay";
|