
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
24 lines
761 B
Diff
24 lines
761 B
Diff
diff --git a/arch/arm/boot/dts/sun8i-a83t.dtsi b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
index afed6c0dea6f..798ab48c5479 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
@@ -992,6 +992,19 @@
|
|
reg = <0x1f01c00 0x400>;
|
|
};
|
|
|
|
+ r_cir: ir@1f02000 {
|
|
+ compatible = "allwinner,sun8i-a83t-ir",
|
|
+ "allwinner,sun5i-a13-ir";
|
|
+ clocks = <&r_ccu CLK_APB0_IR>, <&r_ccu CLK_IR>;
|
|
+ clock-names = "apb", "ir";
|
|
+ resets = <&r_ccu RST_APB0_IR>;
|
|
+ interrupts = <GIC_SPI 37 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ reg = <0x01f02000 0x400>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&r_cir_pin>;
|
|
+ status = "disabled";
|
|
+ };
|
|
+
|
|
r_pio: pinctrl@1f02c00 {
|
|
compatible = "allwinner,sun8i-a83t-r-pinctrl";
|
|
reg = <0x01f02c00 0x400>;
|