
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
20 lines
865 B
Diff
20 lines
865 B
Diff
diff --git a/drivers/clk/sunxi-ng/ccu-sun8i-a83t.c b/drivers/clk/sunxi-ng/ccu-sun8i-a83t.c
|
|
index 7d08015b980d..2d6555d73170 100644
|
|
--- a/drivers/clk/sunxi-ng/ccu-sun8i-a83t.c
|
|
+++ b/drivers/clk/sunxi-ng/ccu-sun8i-a83t.c
|
|
@@ -108,6 +108,7 @@ static struct ccu_nkmp pll_video0_clk = {
|
|
.n = _SUNXI_CCU_MULT_OFFSET_MIN_MAX(8, 8, 0, 12, 0),
|
|
.m = _SUNXI_CCU_DIV(16, 1), /* input divider */
|
|
.p = _SUNXI_CCU_DIV(0, 2), /* output divider */
|
|
+ .max_rate = 3000000000UL,
|
|
.common = {
|
|
.reg = 0x010,
|
|
.lock_reg = CCU_SUN8I_A83T_LOCK_REG,
|
|
@@ -220,6 +221,7 @@ static struct ccu_nkmp pll_video1_clk = {
|
|
.n = _SUNXI_CCU_MULT_OFFSET_MIN_MAX(8, 8, 0, 12, 0),
|
|
.m = _SUNXI_CCU_DIV(16, 1), /* input divider */
|
|
.p = _SUNXI_CCU_DIV(0, 2), /* external divider p */
|
|
+ .max_rate = 3000000000UL,
|
|
.common = {
|
|
.reg = 0x04c,
|
|
.lock_reg = CCU_SUN8I_A83T_LOCK_REG,
|