
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
70 lines
2.5 KiB
Diff
70 lines
2.5 KiB
Diff
diff --git a/drivers/clk/sunxi-ng/ccu-sun8i-r40.c b/drivers/clk/sunxi-ng/ccu-sun8i-r40.c
|
|
index 0f388f6944d5..582ebd41d20d 100644
|
|
--- a/drivers/clk/sunxi-ng/ccu-sun8i-r40.c
|
|
+++ b/drivers/clk/sunxi-ng/ccu-sun8i-r40.c
|
|
@@ -65,19 +65,19 @@ static SUNXI_CCU_NM_WITH_GATE_LOCK(pll_audio_base_clk, "pll-audio-base",
|
|
BIT(28), /* lock */
|
|
CLK_SET_RATE_UNGATE);
|
|
|
|
-/* TODO: The result of N/M is required to be in [8, 25] range. */
|
|
-static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN(pll_video0_clk, "pll-video0",
|
|
- "osc24M", 0x0010,
|
|
- 192000000, /* Minimum rate */
|
|
- 8, 7, /* N */
|
|
- 0, 4, /* M */
|
|
- BIT(24), /* frac enable */
|
|
- BIT(25), /* frac select */
|
|
- 270000000, /* frac rate 0 */
|
|
- 297000000, /* frac rate 1 */
|
|
- BIT(31), /* gate */
|
|
- BIT(28), /* lock */
|
|
- CLK_SET_RATE_UNGATE);
|
|
+static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN_MAX(pll_video0_clk, "pll-video0",
|
|
+ "osc24M", 0x0010,
|
|
+ 192000000, /* Minimum rate */
|
|
+ 1008000000, /* Maximum rate */
|
|
+ 8, 7, /* N */
|
|
+ 0, 4, /* M */
|
|
+ BIT(24), /* frac enable */
|
|
+ BIT(25), /* frac select */
|
|
+ 270000000, /* frac rate 0 */
|
|
+ 297000000, /* frac rate 1 */
|
|
+ BIT(31), /* gate */
|
|
+ BIT(28), /* lock */
|
|
+ CLK_SET_RATE_UNGATE);
|
|
|
|
/* TODO: The result of N/M is required to be in [8, 25] range. */
|
|
static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_ve_clk, "pll-ve",
|
|
@@ -152,19 +152,19 @@ static struct ccu_nk pll_periph1_clk = {
|
|
},
|
|
};
|
|
|
|
-/* TODO: The result of N/M is required to be in [8, 25] range. */
|
|
-static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN(pll_video1_clk, "pll-video1",
|
|
- "osc24M", 0x030,
|
|
- 192000000, /* Minimum rate */
|
|
- 8, 7, /* N */
|
|
- 0, 4, /* M */
|
|
- BIT(24), /* frac enable */
|
|
- BIT(25), /* frac select */
|
|
- 270000000, /* frac rate 0 */
|
|
- 297000000, /* frac rate 1 */
|
|
- BIT(31), /* gate */
|
|
- BIT(28), /* lock */
|
|
- CLK_SET_RATE_UNGATE);
|
|
+static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN_MAX(pll_video1_clk, "pll-video1",
|
|
+ "osc24M", 0x030,
|
|
+ 192000000, /* Minimum rate */
|
|
+ 1008000000, /* Maximum rate */
|
|
+ 8, 7, /* N */
|
|
+ 0, 4, /* M */
|
|
+ BIT(24), /* frac enable */
|
|
+ BIT(25), /* frac select */
|
|
+ 270000000, /* frac rate 0 */
|
|
+ 297000000, /* frac rate 1 */
|
|
+ BIT(31), /* gate */
|
|
+ BIT(28), /* lock */
|
|
+ CLK_SET_RATE_UNGATE);
|
|
|
|
static struct ccu_nkm pll_sata_clk = {
|
|
.enable = BIT(31),
|