
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
41 lines
969 B
Diff
41 lines
969 B
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-nanopi-a64.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-nanopi-a64.dts
|
|
index 1eba1324e5b9..5e3dc2666d0f 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-nanopi-a64.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-nanopi-a64.dts
|
|
@@ -58,6 +58,11 @@
|
|
chosen {
|
|
stdout-path = "serial0:115200n8";
|
|
};
|
|
+
|
|
+ wifi_pwrseq: wifi_pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&r_pio 0 2 GPIO_ACTIVE_LOW>; /* PL2 */
|
|
+ };
|
|
};
|
|
|
|
&ehci0 {
|
|
@@ -105,6 +110,24 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&mmc1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc1_pins>;
|
|
+ vmmc-supply = <®_dcdc1>;
|
|
+ vqmmc-supply = <®_dldo4>;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+ bus-width = <4>;
|
|
+ non-removable;
|
|
+ status = "okay";
|
|
+
|
|
+ rtl8189etv: wifi@1 {
|
|
+ reg = <1>;
|
|
+ interrupt-parent = <&r_pio>;
|
|
+ interrupts = <0 3 IRQ_TYPE_LEVEL_LOW>; /* PL3 */
|
|
+ interrupt-names = "host-wake";
|
|
+ };
|
|
+};
|
|
+
|
|
&ohci0 {
|
|
status = "okay";
|
|
};
|