
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
42 lines
1,001 B
Diff
42 lines
1,001 B
Diff
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
|
index d3daf90a8715..934d7e87fa08 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
|
@@ -134,6 +134,7 @@
|
|
clock-names = "cpu";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
#cooling-cells = <2>;
|
|
+ next-level-cache = <&L2>;
|
|
};
|
|
|
|
cpu1: cpu@1 {
|
|
@@ -142,6 +143,7 @@
|
|
reg = <1>;
|
|
enable-method = "psci";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
+ next-level-cache = <&L2>;
|
|
};
|
|
|
|
cpu2: cpu@2 {
|
|
@@ -150,6 +152,7 @@
|
|
reg = <2>;
|
|
enable-method = "psci";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
+ next-level-cache = <&L2>;
|
|
};
|
|
|
|
cpu3: cpu@3 {
|
|
@@ -158,7 +161,13 @@
|
|
reg = <3>;
|
|
enable-method = "psci";
|
|
operating-points-v2 = <&cpu0_opp_table>;
|
|
+ next-level-cache = <&L2>;
|
|
};
|
|
+
|
|
+ L2: l2-cache {
|
|
+ compatible = "cache";
|
|
+ cache-level = <2>;
|
|
+ };
|
|
};
|
|
|
|
de: display-engine {
|