
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
18 lines
823 B
Diff
18 lines
823 B
Diff
diff --git a/drivers/mtd/spi-nor/spi-nor.c b/drivers/mtd/spi-nor/spi-nor.c
|
|
index 1413828..efc9bfd 100644
|
|
--- a/drivers/mtd/spi-nor/spi-nor.c
|
|
+++ b/drivers/mtd/spi-nor/spi-nor.c
|
|
@@ -935,6 +935,13 @@ static int spi_nor_is_locked(struct mtd_info *mtd, loff_t ofs, uint64_t len)
|
|
|
|
{ "at45db081d", INFO(0x1f2500, 0, 64 * 1024, 16, SECT_4K) },
|
|
|
|
+ /* BergMicro Flashes */
|
|
+ { "bg25q80", INFO(0xe04014, 0, 64 * 1024, 16, SECT_4K) },
|
|
+ { "bg25q16", INFO(0xe04015, 0, 64 * 1024, 32, SECT_4K) },
|
|
+ { "bg25q32", INFO(0xe04016, 0, 64 * 1024, 64, SECT_4K) },
|
|
+ { "bg25q64", INFO(0xe04017, 0, 64 * 1024, 128, SECT_4K) },
|
|
+ { "bg25q128", INFO(0xe04018, 0, 64 * 1024, 256, SECT_4K) },
|
|
+
|
|
/* EON -- en25xxx */
|
|
{ "en25f32", INFO(0x1c3116, 0, 64 * 1024, 64, SECT_4K) },
|
|
{ "en25p32", INFO(0x1c2016, 0, 64 * 1024, 64, 0) },
|