
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
36 lines
1.5 KiB
Diff
36 lines
1.5 KiB
Diff
Increasing the SATA/AHCI DMA TX/RX FIFOs (P0DMACR.TXTS and .RXTS) from
|
|
default 0x0 each to 0x3 each gives a write performance boost of 120MB/s
|
|
from lame 36MB/s to 45MB/s previously. Read performance is about 200MB/s
|
|
[tested on SSD using dd bs=4K count=512K].
|
|
|
|
Tested on the Banana Pi R1 (aka Lamobo R1) and Banana Pi M1 SBCs
|
|
with Allwinner A20 32bit-SoCs (ARMv7-a / arm-linux-gnueabihf).
|
|
These devices are RaspberryPi-like small devices.
|
|
|
|
RFC: Since more than about 25 similar SBC/SoC models do use the
|
|
ahci_sunxi driver, users are encouraged to test it on all the
|
|
affected boards and give feedback.
|
|
|
|
List of the affected sunxi and other boards and SoCs with SATA using
|
|
the ahci_sunxi driver:
|
|
$ grep -i -e "^&ahci" arch/arm/boot/dts/sun*dts
|
|
and http://linux-sunxi.org/Category:Devices_with_SATA_port
|
|
|
|
Signed-off-by: Uenal Mutlu <um@mutluit.com>
|
|
---
|
|
drivers/ata/ahci_sunxi.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/ata/ahci_sunxi.c b/drivers/ata/ahci_sunxi.c
|
|
index 911710643305..257986431c79 100644
|
|
--- a/drivers/ata/ahci_sunxi.c
|
|
+++ b/drivers/ata/ahci_sunxi.c
|
|
@@ -158,7 +158,7 @@ static void ahci_sunxi_start_engine(struct ata_port *ap)
|
|
struct ahci_host_priv *hpriv = ap->host->private_data;
|
|
|
|
/* Setup DMA before DMA start */
|
|
- sunxi_clrsetbits(hpriv->mmio + AHCI_P0DMACR, 0x0000ff00, 0x00004400);
|
|
+ sunxi_clrsetbits(hpriv->mmio + AHCI_P0DMACR, 0x0000ffff, 0x00004433);
|
|
|
|
/* Start DMA */
|
|
sunxi_setbits(port_mmio + PORT_CMD, PORT_CMD_START);
|