
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From 0999574c7b78b85d56ef6ca39684817636773d75 Mon Sep 17 00:00:00 2001
|
|
From: Richard Kojedzinszky <krichy@nmdps.net>
|
|
Date: Sun, 20 Jan 2019 18:43:37 +0100
|
|
Subject: [PATCH] Disable OOB IRQ for wifi on bananapi m1 plus
|
|
|
|
See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908438
|
|
---
|
|
arch/arm/boot/dts/sun7i-a20-bananapi-m1-plus.dts | 16 +++++++++++++---
|
|
1 file changed, 13 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun7i-a20-bananapi-m1-plus.dts b/arch/arm/boot/dts/sun7i-a20-bananapi-m1-plus.dts
|
|
index 763cb03033c4..661b4f90db91 100644
|
|
--- a/arch/arm/boot/dts/sun7i-a20-bananapi-m1-plus.dts
|
|
+++ b/arch/arm/boot/dts/sun7i-a20-bananapi-m1-plus.dts
|
|
@@ -203,9 +203,19 @@
|
|
brcmf: wifi@1 {
|
|
reg = <1>;
|
|
compatible = "brcm,bcm4329-fmac";
|
|
- interrupt-parent = <&pio>;
|
|
- interrupts = <7 15 IRQ_TYPE_LEVEL_LOW>;
|
|
- interrupt-names = "host-wake";
|
|
+ /*
|
|
+ * OOB interrupt support is broken ATM, often the first irq
|
|
+ * does not get seen resulting in the drv probe failing with:
|
|
+ *
|
|
+ * brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
|
|
+ * brcmfmac: brcmf_bus_started: failed: -110
|
|
+ * brcmfmac: brcmf_attach: dongle is not responding: err=-110
|
|
+ * brcmfmac: brcmf_sdio_firmware_callback: brcmf_attach failed
|
|
+ *
|
|
+ * interrupt-parent = <&pio>;
|
|
+ * interrupts = <7 15 IRQ_TYPE_LEVEL_LOW>;
|
|
+ * interrupt-names = "host-wake";
|
|
+ */
|
|
};
|
|
};
|
|
|
|
--
|
|
2.11.0
|
|
|