
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
From 734e26b5a4b061d5f0667d59ce27a4a50f6d5c25 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Thu, 18 Oct 2018 15:07:29 +0800
|
|
Subject: [PATCH 135/146] clk: sunxi-ng: enable so-said LDOs for A64 SoC's
|
|
pll-mipi clock
|
|
|
|
In the user manual of A64 SoC, the bit 22 and 23 of pll-mipi control
|
|
register is called "LDO{1,2}_EN", and according to the BSP source code
|
|
from Allwinner , the LDOs are enabled during the clock's enabling
|
|
process.
|
|
|
|
The clock failed to generate output if the two LDOs are not enabled.
|
|
|
|
Add the two bits to the clock's gate bits, so that the LDOs are enabled
|
|
when the PLL is enabled.
|
|
|
|
Fixes: c6a0637460c2 ("clk: sunxi-ng: Add A64 clocks")
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
drivers/clk/sunxi-ng/ccu-sun50i-a64.c | 7 ++++++-
|
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
|
|
index 90ffee824c33..a637e62ae1c4 100644
|
|
--- a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
|
|
+++ b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
|
|
@@ -162,7 +162,12 @@ static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_gpu_clk, "pll-gpu",
|
|
#define SUN50I_A64_PLL_MIPI_REG 0x040
|
|
|
|
static struct ccu_nkm pll_mipi_clk = {
|
|
- .enable = BIT(31),
|
|
+ /*
|
|
+ * The bit 23 and 22 are called "LDO{1,2}_EN" on the SoC's
|
|
+ * user manual, and by experiments the PLL doesn't work without
|
|
+ * these bits toggled.
|
|
+ */
|
|
+ .enable = BIT(31) | BIT(23) | BIT(22),
|
|
.lock = BIT(28),
|
|
.n = _SUNXI_CCU_MULT(8, 4),
|
|
.k = _SUNXI_CCU_MULT_MIN(4, 2, 2),
|
|
--
|
|
2.17.1
|
|
|