
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From 3d017794525d830a3251bed7ebbacbf74efe9605 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Thu, 18 Oct 2018 15:33:24 +0800
|
|
Subject: [PATCH 131/146] arm64: allwinner: a64: add pinmux for RGB666 LCD
|
|
|
|
Allwinner A64's TCON0 can output RGB666 LCD signal.
|
|
|
|
Add its pinmux.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
|
index cb7d4a96e789..0f5b412cfc81 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
|
@@ -655,6 +655,15 @@
|
|
function = "i2c1";
|
|
};
|
|
|
|
+ lcd_rgb666_pins: lcd-rgb666 {
|
|
+ pins = "PD0", "PD1", "PD2", "PD3", "PD4",
|
|
+ "PD5", "PD6", "PD7", "PD8", "PD9",
|
|
+ "PD10", "PD11", "PD12", "PD13",
|
|
+ "PD14", "PD15", "PD16", "PD17",
|
|
+ "PD18", "PD19", "PD20", "PD21";
|
|
+ function = "lcd0";
|
|
+ };
|
|
+
|
|
mmc0_pins: mmc0-pins {
|
|
pins = "PF0", "PF1", "PF2", "PF3",
|
|
"PF4", "PF5";
|
|
--
|
|
2.17.1
|
|
|