balena-allwinner/layers/meta-balena-allwinner/recipes-kernel/linux/linux-mainline/armbian/0124-drm-lima-Fix-Lima-to-work-with-drm-scheduler-changes.patch
Vicentiu Galanopulo 7d5f1dbda1 recipes-kernel/linux: Remove unused patches and householding
Some patches were part of other linux-mainline
kernel versions but are not anymore part of the
current 4.19.76.

Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch
in linux-mainline_4.19.76.bbappend to avoid error
patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts
Hunk #2 FAILED at 162.
1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts

Place all patches from Armbian in a separate directory and do all the Balena specific
operations in linux-mainline_%.bbappend only.

Changelog-entry: Remove unused patches and cleanup
Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
2019-10-14 09:43:01 +02:00

46 lines
1.5 KiB
Diff

From 2b07a3e1c8918d96db4939c85b5eafcffefd2285 Mon Sep 17 00:00:00 2001
From: Andreas Baierl <ichgeh@imkreisrum.de>
Date: Thu, 4 Oct 2018 06:21:09 -0400
Subject: [PATCH 124/146] drm/lima: Fix Lima to work with drm scheduler changes
since 4.19
Signed-off-by: Andreas Baierl <ichgeh@imkreisrum.de>
---
drivers/gpu/drm/lima/lima_sched.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/gpu/drm/lima/lima_sched.c b/drivers/gpu/drm/lima/lima_sched.c
index 1e715e58d33b..d09aae446883 100644
--- a/drivers/gpu/drm/lima/lima_sched.c
+++ b/drivers/gpu/drm/lima/lima_sched.c
@@ -110,8 +110,7 @@ int lima_sched_task_init(struct lima_sched_task *task,
{
int err;
- err = drm_sched_job_init(&task->base, context->base.sched,
- &context->base, vm);
+ err = drm_sched_job_init(&task->base, &context->base, vm);
if (err)
return err;
@@ -169,7 +168,7 @@ int lima_sched_context_init(struct lima_sched_pipe *pipe,
return -ENOMEM;
mutex_init(&context->lock);
- err = drm_sched_entity_init(&pipe->base, &context->base, rq, guilty);
+ err = drm_sched_entity_init(&context->base, &rq, 1, guilty);
if (err) {
kfree(context->fences);
context->fences = NULL;
@@ -182,7 +181,7 @@ int lima_sched_context_init(struct lima_sched_pipe *pipe,
void lima_sched_context_fini(struct lima_sched_pipe *pipe,
struct lima_sched_context *context)
{
- drm_sched_entity_fini(&pipe->base, &context->base);
+ drm_sched_entity_fini(&context->base);
mutex_destroy(&context->lock);
--
2.17.1