
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
86 lines
2.2 KiB
Diff
86 lines
2.2 KiB
Diff
From d0970394839f5b09d564142c8a4687ef64458586 Mon Sep 17 00:00:00 2001
|
|
From: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
Date: Sun, 3 Dec 2017 11:40:25 -0800
|
|
Subject: [PATCH 122/146] arm64: dts: allwinner: a64: enable sound on Pinebook
|
|
|
|
This commit enables I2S, digital and analog parts of audiocodec on
|
|
Pinebook
|
|
|
|
Signed-off-by: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
---
|
|
.../dts/allwinner/sun50i-a64-pinebook.dts | 42 +++++++++++++++++++
|
|
1 file changed, 42 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
|
|
index dce16d9d6afb..b55ac4e1df37 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
|
|
@@ -71,16 +71,33 @@
|
|
regulator-max-microvolt = <3300000>;
|
|
};
|
|
|
|
+ speaker_amp: speaker_amp {
|
|
+ compatible = "simple-audio-amplifier";
|
|
+ enable-gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
wifi_pwrseq: wifi_pwrseq {
|
|
compatible = "mmc-pwrseq-simple";
|
|
reset-gpios = <&r_pio 0 2 GPIO_ACTIVE_LOW>; /* PL2 */
|
|
};
|
|
};
|
|
|
|
+&codec {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&codec_analog {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&cpu0 {
|
|
cpu-supply = <®_dcdc2>;
|
|
};
|
|
|
|
+&dai {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&de {
|
|
status = "okay";
|
|
};
|
|
@@ -306,6 +323,31 @@
|
|
vcc-hdmi-supply = <®_dldo1>;
|
|
};
|
|
|
|
+&sound {
|
|
+ status = "okay";
|
|
+ simple-audio-card,widgets = "Microphone", "Internal Microphone Left",
|
|
+ "Microphone", "Internal Microphone Right",
|
|
+ "Headphone", "Headphone Jack",
|
|
+ "Speaker", "Internal Speaker";
|
|
+ simple-audio-card,aux-devs = <&codec_analog>, <&speaker_amp>;
|
|
+ simple-audio-card,routing =
|
|
+ "Left DAC", "AIF1 Slot 0 Left",
|
|
+ "Right DAC", "AIF1 Slot 0 Right",
|
|
+ "INL", "LINEOUT",
|
|
+ "INR", "LINEOUT",
|
|
+ "Internal Speaker", "OUTL",
|
|
+ "Internal Speaker", "OUTR",
|
|
+ "Headphone Jack", "HP",
|
|
+ "AIF1 Slot 0 Left ADC", "Left ADC",
|
|
+ "AIF1 Slot 0 Right ADC", "Right ADC",
|
|
+ "Left ADC", "ADC",
|
|
+ "Right ADC", "ADC",
|
|
+ "Internal Microphone Left", "MBIAS",
|
|
+ "MIC1", "Internal Microphone Left",
|
|
+ "Internal Microphone Right", "HBIAS",
|
|
+ "MIC2", "Internal Microphone Right";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_pins_a>;
|
|
--
|
|
2.17.1
|
|
|