
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
31 lines
1 KiB
Diff
31 lines
1 KiB
Diff
From b66aa83817ae94f594e1c1505127530190ef4eba Mon Sep 17 00:00:00 2001
|
|
From: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
Date: Fri, 12 Oct 2018 23:54:55 -0700
|
|
Subject: [PATCH 119/146] ASoC: sunxi: allow the sun8i-codec driver to be built
|
|
on ARM64
|
|
|
|
Allwinner A64 uses the same digital codec part as in A33, so we need
|
|
to build this driver on ARM64 as well.
|
|
|
|
Signed-off-by: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
Acked-by: Maxime Ripard <maxime.ripard@bootlin.com>
|
|
---
|
|
sound/soc/sunxi/Kconfig | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/sound/soc/sunxi/Kconfig b/sound/soc/sunxi/Kconfig
|
|
index 8a055ca1819a..66aad0d3f9c7 100644
|
|
--- a/sound/soc/sunxi/Kconfig
|
|
+++ b/sound/soc/sunxi/Kconfig
|
|
@@ -12,7 +12,7 @@ config SND_SUN4I_CODEC
|
|
config SND_SUN8I_CODEC
|
|
tristate "Allwinner SUN8I audio codec"
|
|
depends on OF
|
|
- depends on MACH_SUN8I || COMPILE_TEST
|
|
+ depends on MACH_SUN8I || (ARM64 && ARCH_SUNXI) || COMPILE_TEST
|
|
select REGMAP_MMIO
|
|
help
|
|
This option enables the digital part of the internal audio codec for
|
|
--
|
|
2.17.1
|
|
|