
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
79 lines
2.5 KiB
Diff
79 lines
2.5 KiB
Diff
From a773d556e204228df20f8622d24a37f400f96f96 Mon Sep 17 00:00:00 2001
|
|
From: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
Date: Sat, 9 Dec 2017 11:15:27 -0800
|
|
Subject: [PATCH 115/146] ASoC: sun8i-codec: Don't hardcode BCLK / LRCK ratio
|
|
|
|
BCLK / LRCK ratio should be sample size * channels, but it was
|
|
hardcoded to 32 (0x1 is 32 as per A33 and A64 datasheets).
|
|
|
|
Calculate it basing on sample size and number of channels.
|
|
|
|
Signed-off-by: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
---
|
|
sound/soc/sunxi/sun8i-codec.c | 22 +++++++++++++++++++---
|
|
1 file changed, 19 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/sound/soc/sunxi/sun8i-codec.c b/sound/soc/sunxi/sun8i-codec.c
|
|
index fb37dd927e33..522a72fde78d 100644
|
|
--- a/sound/soc/sunxi/sun8i-codec.c
|
|
+++ b/sound/soc/sunxi/sun8i-codec.c
|
|
@@ -24,6 +24,7 @@
|
|
#include <linux/io.h>
|
|
#include <linux/pm_runtime.h>
|
|
#include <linux/regmap.h>
|
|
+#include <linux/log2.h>
|
|
|
|
#include <sound/pcm_params.h>
|
|
#include <sound/soc.h>
|
|
@@ -52,7 +53,6 @@
|
|
#define SUN8I_AIF1CLK_CTRL_AIF1_LRCK_INV 13
|
|
#define SUN8I_AIF1CLK_CTRL_AIF1_BCLK_DIV 9
|
|
#define SUN8I_AIF1CLK_CTRL_AIF1_LRCK_DIV 6
|
|
-#define SUN8I_AIF1CLK_CTRL_AIF1_LRCK_DIV_16 (1 << 6)
|
|
#define SUN8I_AIF1CLK_CTRL_AIF1_WORD_SIZ 4
|
|
#define SUN8I_AIF1CLK_CTRL_AIF1_WORD_SIZ_16 (1 << 4)
|
|
#define SUN8I_AIF1CLK_CTRL_AIF1_DATA_FMT 2
|
|
@@ -300,12 +300,23 @@ static u8 sun8i_codec_get_bclk_div(struct sun8i_codec *scodec,
|
|
return best_val;
|
|
}
|
|
|
|
+static int sun8i_codec_get_lrck_div(unsigned int channels,
|
|
+ unsigned int word_size)
|
|
+{
|
|
+ unsigned int div = word_size * channels;
|
|
+
|
|
+ if (div < 16 || div > 256)
|
|
+ return -EINVAL;
|
|
+
|
|
+ return ilog2(div) - 4;
|
|
+}
|
|
+
|
|
static int sun8i_codec_hw_params(struct snd_pcm_substream *substream,
|
|
struct snd_pcm_hw_params *params,
|
|
struct snd_soc_dai *dai)
|
|
{
|
|
struct sun8i_codec *scodec = snd_soc_component_get_drvdata(dai->component);
|
|
- int sample_rate;
|
|
+ int sample_rate, lrck_div;
|
|
u8 bclk_div;
|
|
|
|
/*
|
|
@@ -321,9 +332,14 @@ static int sun8i_codec_hw_params(struct snd_pcm_substream *substream,
|
|
SUN8I_AIF1CLK_CTRL_AIF1_BCLK_DIV_MASK,
|
|
bclk_div << SUN8I_AIF1CLK_CTRL_AIF1_BCLK_DIV);
|
|
|
|
+ lrck_div = sun8i_codec_get_lrck_div(params_channels(params),
|
|
+ params_physical_width(params));
|
|
+ if (lrck_div < 0)
|
|
+ return lrck_div;
|
|
+
|
|
regmap_update_bits(scodec->regmap, SUN8I_AIF1CLK_CTRL,
|
|
SUN8I_AIF1CLK_CTRL_AIF1_LRCK_DIV_MASK,
|
|
- SUN8I_AIF1CLK_CTRL_AIF1_LRCK_DIV_16);
|
|
+ lrck_div << SUN8I_AIF1CLK_CTRL_AIF1_LRCK_DIV);
|
|
|
|
sample_rate = sun8i_codec_get_hw_rate(params);
|
|
if (sample_rate < 0)
|
|
--
|
|
2.17.1
|
|
|