
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
63 lines
1.8 KiB
Diff
63 lines
1.8 KiB
Diff
From 7466a08110850f608e2843a4b8089d184f05fb32 Mon Sep 17 00:00:00 2001
|
|
From: Oskari Lemmela <oskari@lemmela.net>
|
|
Date: Tue, 23 Oct 2018 21:53:25 +0300
|
|
Subject: [PATCH 107/146] arm64: dts: allwinner: axp803: add AC and battery
|
|
power supplies
|
|
|
|
Parts of the AXP803 are compatible with their counterparts on the AXP813.
|
|
Add DT nodes ADC, GPIO, AC and battery power supplies.
|
|
|
|
Signed-off-by: Oskari Lemmela <oskari@lemmela.net>
|
|
Reviewed-by: Quentin Schulz <quentin.schulz@bootlin.com>
|
|
Tested-by: Vasily Khoruzhick <anarsoul@gmail.com>
|
|
---
|
|
arch/arm64/boot/dts/allwinner/axp803.dtsi | 33 +++++++++++++++++++++++
|
|
1 file changed, 33 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/axp803.dtsi b/arch/arm64/boot/dts/allwinner/axp803.dtsi
|
|
index e5eae8bafc42..c3a618e1279a 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/axp803.dtsi
|
|
+++ b/arch/arm64/boot/dts/allwinner/axp803.dtsi
|
|
@@ -49,6 +49,39 @@
|
|
interrupt-controller;
|
|
#interrupt-cells = <1>;
|
|
|
|
+ ac_power_supply: ac-power-supply {
|
|
+ compatible = "x-powers,axp803-ac-power-supply",
|
|
+ "x-powers,axp813-ac-power-supply";
|
|
+ status = "disabled";
|
|
+ };
|
|
+
|
|
+ axp_adc: adc {
|
|
+ compatible = "x-powers,axp803-adc", "x-powers,axp813-adc";
|
|
+ #io-channel-cells = <1>;
|
|
+ };
|
|
+
|
|
+ axp_gpio: gpio {
|
|
+ compatible = "x-powers,axp803-gpio", "x-powers,axp813-gpio";
|
|
+ gpio-controller;
|
|
+ #gpio-cells = <2>;
|
|
+
|
|
+ gpio0_ldo: gpio0-ldo {
|
|
+ pins = "GPIO0";
|
|
+ function = "ldo";
|
|
+ };
|
|
+
|
|
+ gpio1_ldo: gpio1-ldo {
|
|
+ pins = "GPIO1";
|
|
+ function = "ldo";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ battery_power_supply: battery-power-supply {
|
|
+ compatible = "x-powers,axp803-battery-power-supply",
|
|
+ "x-powers,axp813-battery-power-supply";
|
|
+ status = "disabled";
|
|
+ };
|
|
+
|
|
regulators {
|
|
/* Default work frequency for buck regulators */
|
|
x-powers,dcdc-freq = <3000>;
|
|
--
|
|
2.17.1
|
|
|