
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
49 lines
1.6 KiB
Diff
49 lines
1.6 KiB
Diff
From b82507436dc7629f7a1e0ec8fffac4aa42e3c81d Mon Sep 17 00:00:00 2001
|
|
From: Jagan Teki <jagan@amarulasolutions.com>
|
|
Date: Tue, 4 Sep 2018 12:40:49 +0800
|
|
Subject: [PATCH 097/146] dt-bindings: clock: sun50i-a64-ccu: Add PLL_VIDEO0
|
|
macro
|
|
|
|
Allwinner A64 HDMI PHY clock has PLL_VIDEO0 as a parent.
|
|
|
|
Include the macro on dt-bindings so-that the same can be used
|
|
while defining CCU clock phandles.
|
|
|
|
Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
|
|
Reviewed-by: Rob Herring <robh@kernel.org>
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
drivers/clk/sunxi-ng/ccu-sun50i-a64.h | 4 +++-
|
|
include/dt-bindings/clock/sun50i-a64-ccu.h | 1 +
|
|
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/clk/sunxi-ng/ccu-sun50i-a64.h b/drivers/clk/sunxi-ng/ccu-sun50i-a64.h
|
|
index 91f79512cee4..704f038a8496 100644
|
|
--- a/drivers/clk/sunxi-ng/ccu-sun50i-a64.h
|
|
+++ b/drivers/clk/sunxi-ng/ccu-sun50i-a64.h
|
|
@@ -27,7 +27,9 @@
|
|
#define CLK_PLL_AUDIO_2X 4
|
|
#define CLK_PLL_AUDIO_4X 5
|
|
#define CLK_PLL_AUDIO_8X 6
|
|
-#define CLK_PLL_VIDEO0 7
|
|
+
|
|
+/* PLL_VIDEO0 exported for HDMI PHY */
|
|
+
|
|
#define CLK_PLL_VIDEO0_2X 8
|
|
#define CLK_PLL_VE 9
|
|
#define CLK_PLL_DDR0 10
|
|
diff --git a/include/dt-bindings/clock/sun50i-a64-ccu.h b/include/dt-bindings/clock/sun50i-a64-ccu.h
|
|
index d7f42dd22663..e512a1c9b0fc 100644
|
|
--- a/include/dt-bindings/clock/sun50i-a64-ccu.h
|
|
+++ b/include/dt-bindings/clock/sun50i-a64-ccu.h
|
|
@@ -43,6 +43,7 @@
|
|
#ifndef _DT_BINDINGS_CLK_SUN50I_A64_H_
|
|
#define _DT_BINDINGS_CLK_SUN50I_A64_H_
|
|
|
|
+#define CLK_PLL_VIDEO0 7
|
|
#define CLK_PLL_PERIPH0 11
|
|
|
|
#define CLK_CPUX 21
|
|
--
|
|
2.17.1
|
|
|