
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
62 lines
1.8 KiB
Diff
62 lines
1.8 KiB
Diff
From 06cbcf31db7e0f3604f248e1731a0f316837cd64 Mon Sep 17 00:00:00 2001
|
|
From: Jagan Teki <jagan@amarulasolutions.com>
|
|
Date: Tue, 4 Sep 2018 12:40:46 +0800
|
|
Subject: [PATCH 094/146] drm/sun4i: Add support for A64 mixers
|
|
|
|
Mixers in Allwinner have similar capabilities as others SoCs with DE2.
|
|
|
|
Add support for them.
|
|
|
|
Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
|
|
[Icenowy: Add mixer1]
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
Reviewed-by: Jernej Skrabec <jernej.skrabec@siol.net>
|
|
---
|
|
drivers/gpu/drm/sun4i/sun8i_mixer.c | 24 ++++++++++++++++++++++++
|
|
1 file changed, 24 insertions(+)
|
|
|
|
diff --git a/drivers/gpu/drm/sun4i/sun8i_mixer.c b/drivers/gpu/drm/sun4i/sun8i_mixer.c
|
|
index cb65b0ed53fd..091f6cf40353 100644
|
|
--- a/drivers/gpu/drm/sun4i/sun8i_mixer.c
|
|
+++ b/drivers/gpu/drm/sun4i/sun8i_mixer.c
|
|
@@ -553,6 +553,22 @@ static const struct sun8i_mixer_cfg sun8i_v3s_mixer_cfg = {
|
|
.mod_rate = 150000000,
|
|
};
|
|
|
|
+static const struct sun8i_mixer_cfg sun50i_a64_mixer0_cfg = {
|
|
+ .ccsc = 0,
|
|
+ .mod_rate = 297000000,
|
|
+ .scaler_mask = 0xf,
|
|
+ .ui_num = 3,
|
|
+ .vi_num = 1,
|
|
+};
|
|
+
|
|
+static const struct sun8i_mixer_cfg sun50i_a64_mixer1_cfg = {
|
|
+ .ccsc = 1,
|
|
+ .mod_rate = 297000000,
|
|
+ .scaler_mask = 0x3,
|
|
+ .ui_num = 1,
|
|
+ .vi_num = 1,
|
|
+};
|
|
+
|
|
static const struct of_device_id sun8i_mixer_of_table[] = {
|
|
{
|
|
.compatible = "allwinner,sun8i-a83t-de2-mixer-0",
|
|
@@ -570,6 +586,14 @@ static const struct of_device_id sun8i_mixer_of_table[] = {
|
|
.compatible = "allwinner,sun8i-v3s-de2-mixer",
|
|
.data = &sun8i_v3s_mixer_cfg,
|
|
},
|
|
+ {
|
|
+ .compatible = "allwinner,sun50i-a64-de2-mixer-0",
|
|
+ .data = &sun50i_a64_mixer0_cfg,
|
|
+ },
|
|
+ {
|
|
+ .compatible = "allwinner,sun50i-a64-de2-mixer-1",
|
|
+ .data = &sun50i_a64_mixer1_cfg,
|
|
+ },
|
|
{ }
|
|
};
|
|
MODULE_DEVICE_TABLE(of, sun8i_mixer_of_table);
|
|
--
|
|
2.17.1
|
|
|