
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
84 lines
2.9 KiB
Diff
84 lines
2.9 KiB
Diff
From 8a348934a01914c7e6ada897d7ba121209961032 Mon Sep 17 00:00:00 2001
|
|
From: Jagan Teki <jagan@amarulasolutions.com>
|
|
Date: Tue, 4 Sep 2018 12:40:43 +0800
|
|
Subject: [PATCH 091/146] clk: sunxi-ng: a64: Add minimal rate for video PLLs
|
|
|
|
According to documentation and experience with other similar SoCs, video
|
|
PLLs don't work stable if their output frequency is set below 192 MHz.
|
|
|
|
Because of that, set minimal rate to both A64 video PLLs to 192 MHz.
|
|
|
|
Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
Reviewed-by: Jernej Skrabec <jernej.skrabec@siol.net>
|
|
---
|
|
drivers/clk/sunxi-ng/ccu-sun50i-a64.c | 46 ++++++++++++++-------------
|
|
1 file changed, 24 insertions(+), 22 deletions(-)
|
|
|
|
diff --git a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
|
|
index 7c645f2c017a..40a7b5fd091c 100644
|
|
--- a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
|
|
+++ b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
|
|
@@ -64,17 +64,18 @@ static SUNXI_CCU_NM_WITH_GATE_LOCK(pll_audio_base_clk, "pll-audio-base",
|
|
BIT(28), /* lock */
|
|
CLK_SET_RATE_UNGATE);
|
|
|
|
-static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_video0_clk, "pll-video0",
|
|
- "osc24M", 0x010,
|
|
- 8, 7, /* N */
|
|
- 0, 4, /* M */
|
|
- BIT(24), /* frac enable */
|
|
- BIT(25), /* frac select */
|
|
- 270000000, /* frac rate 0 */
|
|
- 297000000, /* frac rate 1 */
|
|
- BIT(31), /* gate */
|
|
- BIT(28), /* lock */
|
|
- CLK_SET_RATE_UNGATE);
|
|
+static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN(pll_video0_clk, "pll-video0",
|
|
+ "osc24M", 0x010,
|
|
+ 192000000, /* Minimum rate */
|
|
+ 8, 7, /* N */
|
|
+ 0, 4, /* M */
|
|
+ BIT(24), /* frac enable */
|
|
+ BIT(25), /* frac select */
|
|
+ 270000000, /* frac rate 0 */
|
|
+ 297000000, /* frac rate 1 */
|
|
+ BIT(31), /* gate */
|
|
+ BIT(28), /* lock */
|
|
+ CLK_SET_RATE_UNGATE);
|
|
|
|
static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_ve_clk, "pll-ve",
|
|
"osc24M", 0x018,
|
|
@@ -125,17 +126,18 @@ static struct ccu_nk pll_periph1_clk = {
|
|
},
|
|
};
|
|
|
|
-static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_video1_clk, "pll-video1",
|
|
- "osc24M", 0x030,
|
|
- 8, 7, /* N */
|
|
- 0, 4, /* M */
|
|
- BIT(24), /* frac enable */
|
|
- BIT(25), /* frac select */
|
|
- 270000000, /* frac rate 0 */
|
|
- 297000000, /* frac rate 1 */
|
|
- BIT(31), /* gate */
|
|
- BIT(28), /* lock */
|
|
- CLK_SET_RATE_UNGATE);
|
|
+static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN(pll_video1_clk, "pll-video1",
|
|
+ "osc24M", 0x030,
|
|
+ 192000000, /* Minimum rate */
|
|
+ 8, 7, /* N */
|
|
+ 0, 4, /* M */
|
|
+ BIT(24), /* frac enable */
|
|
+ BIT(25), /* frac select */
|
|
+ 270000000, /* frac rate 0 */
|
|
+ 297000000, /* frac rate 1 */
|
|
+ BIT(31), /* gate */
|
|
+ BIT(28), /* lock */
|
|
+ CLK_SET_RATE_UNGATE);
|
|
|
|
static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_gpu_clk, "pll-gpu",
|
|
"osc24M", 0x038,
|
|
--
|
|
2.17.1
|
|
|