
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 99b4088bcefec2a055c1d7caa1f135168405ccf1 Mon Sep 17 00:00:00 2001
|
|
From: Giulio Benetti <giulio.benetti@micronovasrl.com>
|
|
Date: Tue, 2 Oct 2018 23:59:17 +0200
|
|
Subject: [PATCH 090/146] drm/sun4i: tcon: prevent tcon->panel dereference if
|
|
null
|
|
|
|
If using tcon with VGA, tcon->panel will be null(0), this will cause
|
|
segmentation fault when trying to dereference tcon->panel->connector.
|
|
|
|
Add tcon->panel null check before calling
|
|
sun4i_tcon0_mode_set_dithering().
|
|
|
|
Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
|
|
---
|
|
drivers/gpu/drm/sun4i/sun4i_tcon.c | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/gpu/drm/sun4i/sun4i_tcon.c b/drivers/gpu/drm/sun4i/sun4i_tcon.c
|
|
index 0d438f633b5d..1b28fd9c2908 100644
|
|
--- a/drivers/gpu/drm/sun4i/sun4i_tcon.c
|
|
+++ b/drivers/gpu/drm/sun4i/sun4i_tcon.c
|
|
@@ -490,7 +490,8 @@ static void sun4i_tcon0_mode_set_rgb(struct sun4i_tcon *tcon,
|
|
sun4i_tcon0_mode_set_common(tcon, mode);
|
|
|
|
/* Set dithering if needed */
|
|
- sun4i_tcon0_mode_set_dithering(tcon, tcon->panel->connector);
|
|
+ if (tcon->panel)
|
|
+ sun4i_tcon0_mode_set_dithering(tcon, tcon->panel->connector);
|
|
|
|
/* Adjust clock delay */
|
|
clk_delay = sun4i_tcon_get_clk_delay(mode, 0);
|
|
--
|
|
2.17.1
|
|
|